Приложение на старых iOS устройствах

Avatar
  • обновлен
  • Отклонен

Речь пойдет о Кинопоиск HD для iOS. На планшете стоит iOS 9.3.5, при попытке скачивания приложения из AppStore он выдаёт ошибку совместимости приложения (требует минимум iOS 11). Очень не хочется обновлять айпэд из-за вашего одного приложения. Просим вас сделать так, чтобы со старыми версиями тоже работало)

Прикрепленные ответы
Avatar
0
Кинопоиск
  • Ответ
  • Отклонен

Мы бы очень хотели, чтобы приложение работало на старых моделях мобильных устройств, но это невозможно из-за того, что старые устройства не умеют работать с современными модулями и скриптами. 

Например — модуль DRM защиты Widevine, который мы обязаны использовать для защиты контента от копирования, предоставляется и поддерживается компанией Google. То есть, в данном случае мы со своей стороны ничего сделать не можем - модуль не будет работать при просмотре контента на старых устройствах, не понимающих его.

Avatar
0
Кинопоиск
  • Ответ
  • Отклонен

Мы бы очень хотели, чтобы приложение работало на старых моделях мобильных устройств, но это невозможно из-за того, что старые устройства не умеют работать с современными модулями и скриптами. 

Например — модуль DRM защиты Widevine, который мы обязаны использовать для защиты контента от копирования, предоставляется и поддерживается компанией Google. То есть, в данном случае мы со своей стороны ничего сделать не можем - модуль не будет работать при просмотре контента на старых устройствах, не понимающих его.

Avatar
0
Андрей Фетисов
Цитата от Кинопоиск

Мы бы очень хотели, чтобы приложение работало на старых моделях мобильных устройств, но это невозможно из-за того, что старые устройства не умеют работать с современными модулями и скриптами. 

Например — модуль DRM защиты Widevine, который мы обязаны использовать для защиты контента от копирования, предоставляется и поддерживается компанией Google. То есть, в данном случае мы со своей стороны ничего сделать не можем - модуль не будет работать при просмотре контента на старых устройствах, не понимающих его.

Здравствуйте! Смотрю требования к поддержке DRM Widevine https://drmnow.ru/drm/ и вижу что iPad (3-го поколения) поддерживает все необходимое:

  1. Плеер html5 c поддержкой DRM
  2. DRM License servers — серверы DRM, предоставляющие лицензию
  3. DRM KeyServer — сервер ключей защиты
  4. Permissions / GeoIP — сервер, отвечающий за принятие решения о разрешении просмотра видео
  5. Протестировал поддержку DRM в сервисе плеер html5 с поддержкой DRM и VAST 3.0/VPAID 2.0 она есть

Так почему не можете сделать поддержку приложения кинопоиск в ipad 3 ? Или почему веб версия кинопоиска в браузере не работает? Веть youtube например в браузере прекрасно работает! 

ЗЫ

Буду пробовать запустить кинопоиск на своем ipad 3 у себя на сайте, смотрите может что получится: https://itshnikfix.ru/2022/06/12/kak-givetsya-s-ipad-3-v-2022/